Configurar Firefox 50 y evitar error libavcodec

En la nueva versión Firefox 50 han establecido que no se pueda usar la librería de decodificación de vídeo libavcodec anterior a la versión 54.35.1 debido a los problemas de seguridad que puede causar.


Las instrucciones que indico a continuación sirven tanto para Ubuntu como para todas sus derivadas.

Libavcodec y Ubuntu 16.04

Si estás usando una versión de Ubuntu 16.04 o mas reciente, bastará con que lo tengas actualizado para evitar el problema.

Libavcodec y Ubuntu 14.04

Si lo que tienes es una versión Ubuntu 14.04 es necesario que actualices los repositorios que facilitan esa librería.
Para ello se debe instalar el ppa: heyarje/libav-11
A continuación hay que actualizar e instalar el paquete libav-tools y las librerías actualizadas con los comando abajo indicados:

sudo add-apt-repository ppa:heyarje/libav-11
sudo apt-get update
sudo apt-get install libav-tools libavcodec-extra-56
sudo apt-get upgrade

Libavcodec y Ubuntu 12.04

Sin embargo si todavía estás utilizando una versión de Ubuntu 12.04 no podrás actualizar a las nuevas versiones y tendrás el molesto mensaje cada vez que abras una pagina que tenga un vídeo insertado.

Para evitarlo puedes configurar Firefox para que abra vídeos de forma no segura.

En el navegados escribes: about:config.
Te sale un mensaje de no apto para manazas, y pulsas la tecla intro.
Ahora en el buscador pones libavcodec y una de las lineas que aparecen es:

media.libavcodec.allow-obsolete

que está en valor false, y que hay que cambiarlo a valor true

Cierras la pestaña y reinicias el navegador y a partir de ese momento ya no vuelve a salir el mensaje.

Fuente 
Fuente 

Comentarios